[klibc] problems with ipconfig command (no static config possible)

Dirk von Suchodoletz dirk at goe.net
Wed Aug 25 17:24:40 PDT 2004

> ...
> > state. So the eth0 is not seen by ipconfig, and your ip= line contains
> > no interface. As a result, no config happens if the interface data are
> > specified manually.
> > 
> > this simple patch uses sysfs to find the available interfaces, it adds
> > only ethernet links.
> > 
> I don't think that's a good idea; after all, there *are* other legitimate boot
> targets (FDDI seems to have its own ARPHDR constant which is weird since it
> uses IEEE MAC addresses, but there is at least Arcnet and EUI64.)

I tried the 167 of the klibc code (especially ipconfig and nfsmount) 
yesterday. Everything worked fine, if I added the interface to the
ip= line from either PXE or etherboot. Unfortunately etherboot puts a 
hostname into this line and PXE not. If I simply pass the line without 
addition to ipconfig then the loopback device is configured (That seems to 
me of no much sense :-( ) ...

Any ideas how this could be solved?

My hack by now is either "ipconfig -c none $ip::eth0" or
"ipconfig -c none $ip:eth0" depending on the type of bootsoftware used.

Thanks and ciao!!


More information about the klibc mailing list