[klibc] [patch] bitops.h don't use likely/unlikely outside __KERNEL__

Arnd Bergmann arnd at arndb.de
Tue Jun 20 15:51:56 PDT 2006

On Wednesday 21 June 2006 00:27, H. Peter Anvin wrote:
> More fundamentally busted seems to be that this function gets included at all from a 
> userspace build.  This chain seems to be <sys/types.h> -> <linux/posix_types.h> -> -> 
> <asm/posix_types.h> -> <asm/bitops.h>.
> This appears to come from the definitions of __FD_*() in <asm/posix_types.h>; it would 
> probably be cleaner to just open-code those, since they don't need stuff like ffs/ffz.
That change is already in the queue for 2.6.18, IIRC. Dwmw2 stumbled over it as well
in the headers_install tree.

	Arnd <><

More information about the klibc mailing list