[klibc] [git patch] klibc bzero, mount fixes + random stuff

H. Peter Anvin hpa at zytor.com
Fri Aug 24 15:59:58 PDT 2007


maximilian attems wrote:
> hello hpa,
> 
> please pull for the latest
> git pull git://brane.itp.tuwien.ac.at/~mattems/klibc.git maks
> 

Hi there,

Please implement bzero() as memset(x, 0, y); instead of open-coding it
as a zero loop.

strcspn/strpbrk/strspn: use "" quotes for files in usr/klibc; but
<string.h> comes from usr/include and should be in <>.

Also, I would appreciate it if you would add [klibc] to the checkin
descriptions.

The warnings you get come from these declarations:

static __inline__ int getpagesize(void)
{
        extern unsigned int __page_size;
        return __page_size;
}

-Wnested outlaws these kinds of constructs.  There is a __nowarn__
keyword being added in gcc 4.3 or 4.4 to shut up these kinds of
warnings, but the only other way to deal with this is to export
__page_size and __page_shift into the global namespace, which kind of
defeats the purpose of an accessor function.

	-hpa



More information about the klibc mailing list