[klibc] version compatibility between linux and klibc

Phil Howard kunnskaperen at gmail.com
Wed Jul 7 17:22:33 PDT 2010

On Tue, Jul 6, 2010 at 2:29 PM, Sam Ravnborg <sam at ravnborg.org> wrote:

> On Sun, Jul 04, 2010 at 08:30:03PM -0400, Phil Howard wrote:
> > Are there any version compatibilities between linux and klibc?  I tried
> to
> > compile the latest klibc (1.5.18) with the latest linux ( and
> > there is miserable compile failures.  It looks like klibc wants some
> headers
> > to be in include/asm (linked in my case to include/asm-x86) but they are
> > instead in include/asm-generic (it seems all headers but one are in
> there).
> >
> > I put together this script to be sure I was doing the steps consistently
> for
> > each attempt (and also starting with a pristine set of files each time):
> >
> > http://phil.ipal.org/linux-and-klibc/compile-linux-and-klibc
> >
> > Here is one of the bad results (running the above script):
> >
> >
> http://phil.ipal.org/linux-and-klibc/20100704-200321-025257-compile-linux-and-klibc.log
> >
> > I added a step to copy include/asm-generic to include/asm and that seemed
> to
> > help some.  But there was nothing in the README files about needing to do
> > that.  Here is a lot of that result:
> The above is wrong - klibc today should be built using exported headers.

Well, I didn't know if that was right or wrong.  It was just a guess.  I
made the guess on the basis that header files had been re-arranged in the
kernel tree and it looked like they had been split apart.  The theory was to
recombine them back.  Since it did change thing and compilation went
further, I figured I'd mention that.

I tried with latest klibc + kernel.
> This worked for me:
> cd $KERNEL
> make headers_install
> cd $KLIBC

OK, so for recent kernels, it is no longer sufficient to just symlink into a
configured kernel source tree.

Note that "headers_install" install the userspace ready headers in
> $KERNEL/usr
> which is why this dir is specified as argument to KLIBCKERNELSRC.

OK, so I won't have to su to root to install them in /usr/src.  I hope I
have some time tonight to test it out (after looking through subsequent
posts to see if there are other things to do).  If not tonight, surely
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.zytor.com/pipermail/klibc/attachments/20100707/2bb8fda9/attachment.html>

More information about the klibc mailing list